[Context] [Bug 319036] Re: Minimals distributes old Windows luatex binary that doesn't work with ConTeXt distributions (current, beta, alpha, 2008.10.31)

Patrick Gundlach patrick at gundla.ch
Tue Jan 20 07:57:21 CET 2009


Thank you for the report!

Internal note: 
I have just moved the update process to a new server. Perhaps I did something wrong. We need to check on the server if the synch with the windows binaries from Akira(?) works as expected. 

Patrick

-- 
Minimals distributes old Windows luatex binary that doesn't work with ConTeXt distributions (current, beta, alpha, 2008.10.31)
https://bugs.launchpad.net/bugs/319036
You received this bug notification because you are a member of ConTeXt
distribution team, which is the registrant for ConTeXt distribution.

Status in ConTeXt distribution: New

Bug description:
Is it possible to distribute a newer Windows luatex binary?

I installed ConTeXt on a Windows XP SP2 system following the instructions at http://wiki.contextgarden.net/ConTeXt_Minimals#Windows under the heading "Installation: local & command-line." Then, compiling the traditional test file:

\starttext
Hello, world!
\stoptext

bombed. I am happy to reproduce the errors and attach log files, but to cut to the chase it seems that the old Windows luatex binary presently distributed at minimals.contextgarden.net doesn't play nice with recent ConTeXt distributions. I tried current, alpha, beta, and 2008.10.31, which all failed.

I then reinstalled minimals with --context=beta, grabbed the latest Windows luatex binary from http://foundry.supelec.fr/frs/?group_id=10 (currently beta 0.30.3) and copied the newer luatex binary over the old one in c:\context\tex\texmf-mswin\bin. I then ran luatools --selfupdate, mtxrun --selfupdate, luatools --generate, context --make en. Now the simple test document and other more complicated documents compile just fine.




More information about the binary-builders mailing list